Error: httpd24-tools conflicts with httpd-tools-2.2.31-1.7.amzn1.x86_64

古いhttpdをremoveしてから新しいものを再インストールすると

Error: httpd24-tools conflicts with httpd-tools-2.2.31-1.7.amzn1.x86_64

というエラーがでることがあります。新しいhttp24-toolsが古いものとコンフリクト起こしているという話なんで、古い方を削除ということになります。

# rpm -qa | grep httpd
httpd-tools-2.2.31-1.7.amzn1.x86_64

まだいることが確認できたら、

# yum remove httpd-tools-2.2.31-1.7.amzn1.x86_64

で削除。再度yumで新しいhttpdをインストールすればOKです。

# yum -y install httpd24

これでOK

Last update: 2016.06.09 (木)